Laboratory Manual to the Course Microprocessors (CENG 329)

EXPERIMENT 2


ÇANKAYA UNIVERSITY

COMPUTER ENGINEERING DEPARTMENT

EXPERIMENT 2

GETTING STARTED WITH THE Z8 Encore!( PROCESSOR
OBJECTIVE

This set of experiments continues familiarization with the characteristics of Zilog Developer Studio II – Z8 Encore!®  and shows work of additional components that complete process of designing of software to systems with embedded 8 – bit Z8 Encore! microcontroller. 

1. THEORY

1.1. EMULATOR QUICK TOUR

Use the Debugging Quick Tour in conjunction with this quick tour. Follow the steps in this section for changing the CPU and setting up the emulator and then return to the Debugging Quick Tour. 

1.1.1. Change CPU Selection

The CPU selection must be supported by the emulator you are using. Make sure the CPU Family and CPU drop-down list boxes on the Project Settings dialog box (General tab) are set appropriately. From the Project Settings dialog box, select the General tab. The options on the General tab (Figure 1) are described in this section.
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Figure 1. Project Settings Dialog Box–General Tab
CPU Family The CPU Family drop-down list box allows you to select the appropriate Z8 Encore! family.

CPU The CPU drop-down list box defines which CPU you want to define for the Z8 Encore! target.
To change the CPU for your project, select the appropriate CPU in the CPU drop-down list box.

NOTE: Selecting a CPU does not automatically select include files for your C or assembly source code. Include files must be manually included in your code. Selecting a new CPU automatically updates the ROM range for that CPU.

Output Files Directory. The Output Files Directory field contains the path where your output files are created and stored. For more information for output files for the linker, see “Linker Commands”. 

1.1.2. Set Up the Serial Smart Cable
Use the following procedure to configure the emulator through the serial Smart Cable:

1. From the Project menu, select Settings.

2. Click the Debugger tab.

3. Select the Serial check box.

4. Select a serial target from the Select Target area.

5. Click Communication. The Setup Serial Communication dialog box is displayed.

a. Use the Baud Rate drop-down list box to select the appropriate baud rate: 19200, 38400, 57600, or 115200. The default is 57600.

b. Use the Port drop-down list box to select the appropriate port: COM1, COM2, COM3, COM4, COM5, COM6, COM7, COM8, COM9, COM10, COM11, COM12, COM13, COM14, COM15, or COM16. The default is COM1.

c. Click OK to close and save the settings for the Setup Serial Communication dialog box and return to the Project Settings dialog box.

6. Click Setup. The Setup Target dialog box is displayed.

a. Select the appropriate clock frequency in the Clock Frequency (MHz) area or enter the clock frequency in the Other field. This frequency must match the clock oscillator on Y4 of the emulator. 

NOTE: The emulator clock cannot be supplied from the target application board.

b. Click OK to close and save the settings for the Setup Target dialog box and return to the Project Settings dialog box.

7. Click OK to close and save the settings for the Project Settings dialog box. 
Now return to “Switch to Debug Mode” on Laboratory Experiments 1 in the Debugging Quick Tour and follow the procedures in that tour.

1.2. INSTRUCTION SET SIMULATOR QUICK TOUR
Use the Debugging Quick Tour in conjunction with this tour. Follow the steps in this section for changing the CPU, setting up the simulator, and then returning to the Debugging Quick Tour. Drivers are used to manage communication between your PC and the target device. A target device can be either an emulator or a simulator. By selecting a driver from the Driver drop-down list box on the Project Settings dialog box (Debugger tab), you define where your code runs.

1.2.1. Change CPU Selection
The CPU selection must be supported by the driver you are using. Make sure the CPU Family and CPU drop-down list boxes on the Project Settings dialog box (General tab) are set appropriately. (See “General Tab”).

1.2.2. Set Up the Simulator
For the purpose of the Debugging Quick Tour, a default driver has been selected for you. Make sure the default driver, the Z8 Encore! Simulator, is applicable for your intended use.

1. Select Settings from the Project menu.

2. Click the Debugger tab.

3. Select the Simulator check box in the Select Target area.
4. Click Setup. The Setup Simulator dialog box (Figure 2) is displayed.
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Figure 2. Setup Simulator Dialog Box 
5. In the Clock Speed (MHz) field, type the appropriate speed. The default is 20.0000.

6. Move the thumb bar or scroll the scroll bar to adjust the Simulator Throttle from 1% to 100%. A 1% throttle means that the simulator uses approximately 1% of the system's resources while executing your program's instructions. This leaves plenty of power to do other things while the simulator is running. A throttle of 100% uses virtually all of your CPU’s processing time to execute your program, allowing it to complete faster but slows any other Windows functions down considerably. The recommended setting is 50%.

7. Select the Load Memory Files check box if you want the debugger to automatically load your memory files into the target platform's memory each time the debugger is executed.

8. Select the Write Memory Files check box if you want the debugger to automatically write your memory files into the target platform's memory each time the debugger is executed.

9. Click OK to close and save the settings for the Setup Simulator dialog box.

10. Click OK to close and save the settings for the Project Settings dialog box. Now return to “Switch to Debug Mode” in the Debugging Quick Tour and follow the procedures in that tour.
1.3. COMMAND PROCESSOR QUICK TOUR
The Command Processor allows you to use commands or script files to automate the execution of a significant portion of the Integrated Development Environment’s (IDE) functionality. You can run commands in one of the following ways:

• Using the Command Processor toolbar in the IDE.

Commands entered into the Command Processor toolbar are executed after you press the Enter (or Return) key or click the Run Command button.

• Using the batch command to run a command script file from the Command Processor toolbar. For example: 

batch "c:\path\to\command\file\runall.cmd" 

batch "commands.txt"

• Using the command script file when the IDE is started. You need to precede the script file with an at symbol (@) when passing the command file to the IDE on the command line. For example:

zds2ide @c:\path\to\command\file\runall.cmd

zds2ide @commands.txt

Commands and associated results are displayed in the Command Output window in the IDE and, if logging is enabled (see “log”), in the log file as well. You can prevent commands from being displayed by preceding a command with an at (@) symbol (for example, @print "hello"), but the results are still displayed.
1.3.1. Write a Command Script File
A script file is a text-based file that contains a collection of commands. The file can be created with any editor that can save or export files in a text-based format. Each command must be listed on its own line. Anything following a semicolon (;) is considered a comment.
Sample Command Script File

; change to correct default directory 

cd "m:\Z8Encore\test\focustests" 

open project "focus1.zdsproj" 

log "focus1.log" ; Create log file 

log on ; Enable logging 

rebuild 

reset bp 

done 

go 

wait 2000 ; Wait 2 seconds 

print "pc = %x" reg PC 

log off ; Disable logging 

quit ; Exit debug mode 

open project "focus2.zdsproj" 

reset 

bp done 

go 

wait 2000 ; Wait 2 seconds 

log "focus2.log" ; Open log file 

log on ; Enable logging 

print "pc = %x" reg PC 

log off ; Disable logging 

quit ; Exit debug mode

This script consecutively opens two projects, sets a breakpoint at label done, runs to the breakpoint, and logs the value of the PC register. After the second project is complete, the script exits the IDE. The first project is also rebuilt.

1.3.2. Supported Script File Commands 
Table 1, page 27 (See ZiLOG Developer Studio II – Z8 Encore!(, User Manual, UM0 13026 – 0105) lists ZDS II menu commands and dialog box options that have corresponding script file commands.
Commands are not case sensitive. In directory or path-based parameters, you can use \, \\, or / as separators as long as you use the same separator throughout a single parameter. For example, the following examples are legal:

cd "..\path\to\change\to" 

cd "..\\path\\to\\change\\to" 

cd "../path/to/change/to"

The following examples are illegal:

cd "..\path/to\change/to" 

cd "..\\path\to\change\to"

1.3.3. Running the Flash Loader from the Command Processor
You can run the Flash Loader from the Command field. Command Processor keywords have been added to allow for easy scripting of the Flash loading process. Each of the parameters is persistent, which allows for the repetition of the Flash and verification processes with a minimum amount of repeated keystrokes. Use the following procedure to run the Flash Loader:

1. Create a project or open a project with a Z8 Encore! microcontroller selected in the CPU Family and CPU fields of the General tab of the Project Settings dialog box (see “General Tab”). 2. Use the Setup Serial Communication dialog box (see “Communication Button”) to select the communication port to which the target is connected and select the communication port baud rate. 

3. In the Command field (in the Command Processor toolbar), type in one of the following command sequence to use the Flash Loader.

Displaying Flash Help
Flash Setup 

Displays the Flash setup in the Command Output window

Flash Help 

Displays the Flash command format in the Command Output window
Setting Up Flash Options 
Flash Options "<File Name>" 



File to be flashed

Flash Options OFFSET = "<address>" 


Offset address in hex file

Flash Options INTMEM 




Set to internal memory

Flash Options NEBF





Do not erase before flash

Flash Options EBF 





Erase before flash

Flash Options NISN





Do not include serial number 

Flash Options ISN





Include a serial number

Flash Options SERIALADDRESS = "<address>" 

Serial number address

Flash Options SERIALNUMBER = "<Number in Hex>" 
Initial serial number value

Flash Options SERIALSIZE = <1-8> 


Number of bytes in serial number Flash Options INCREMENT = "<Decimal value>" 

Increment value for serial number

Executing Flash Commands
Flash READSERIAL


Read the serial number

Flash READSERIAL REPEAT
Read the serial number and repeat

Flash BURNSERIAL


Burn the serial number

Flash BURNSERIAL REPEAT
Burn the serial number and repeat

Flash ERASE



Erase Flash memory

Flash ERASE REPEAT 

Erase Flash memory and repeat

Flash BURN 



Burn Flash memory

Flash BURN REPEAT

Burn Flash memory and repeat

Flash BURNVERIFY 

Burn and verify Flash memory 

Flash BURNVERIFY REPEAT 
Burn and verify Flash memory and repeat

Flash VERIFY


Verify
Flash memory 

Flash VERIFY REPEAT 

Verify Flash memory and repeat

Caution: The Flash Loader dialog box and the Command Processor interface use the same parameters. If an option is not specified with the Command Processor interface, the current setting in the Flash Loader dialog box is used. If a setting is changed in the Command Processor interface, the Flash Loader dialog box settings are changed. 
Examples. The following are valid examples:

FLASH Options INTMEM 

FLASH Options "c:\testing\test.hex" 

FLASH BURN REPEAT

Or

flash options intmem 

flash options "c:\testing\test.hex" 

flash burn repeat

The file test.hex is loaded into internal Flash memory. After the flashing is completed, you are prompted to program an additional unit. 

FLASH VERIFY

The file test.hex is verified against internal Flash memory.
FLASH SETUP

The current Flash Loader parameters settings are displayed in the Command Output window.

FLASH HELP

The current Flash Loader command options are displayed in the Command Output window.

1.4. RUNNING THE EVENT SYSTEM FROM THE COMMAND PROCESSOR
The ZDS II—Z8 Encore! F642X Emulator allows you to run the event system from the Command Processor toolbar. You can use Command Processor keywords to set up, enable, and disable the event system. Each of the parameters is persistent, which allows for the repetition of the event settings with a minimum amount of repeated data entry. There are four individual event states supported by the emulator:

•EVENT :0

•EVENT :1

•EVENT :2

•EVENT :3

The following command structure is supported for the event system using the Command Processor toolbar:
Note: <> indicates optional commands; [] indicates required commands; [sp] indicates the space character; “####” indicates a hexadecimal number with required quotation marks. The entries are not case sensitive.
[EVENT][sp]<:Event#>[sp][WHEN][sp]<PC="####">[sp]<AND>[sp]<PCMASK ="####">[sp]<AND>[sp]<REGADDR="###">[sp]<AND>[sp]<RAMASK= "###">[sp] <AND>[sp]<REGDATA="##">[sp]<AND>[sp]<RDMASK="##"> [sp]<AND>[sp]<REGREAD[sp]ON|OFF>[sp]<AND> [sp]<REGWRITE[sp]ON| OFF> [sp]<AND>[sp] <FLAGS="##">[sp]<AND> [sp]<FMASK= "##">[sp] <AND>[sp]<TRIGGERIN ON | OFF>[sp][THEN][sp]<TRACE ON | OFF | WHILETRUE>[sp]<AND>[sp] <BREAK[sp]ON | OFF>[sp]<AND>[sp] <TRIGGEROUT[sp]DISABLE|PULSE|TOGGLE> [sp]<AND>[sp]<ARMNEXTEVENT [sp]ON | OFF>

These keywords and options are defined as follows

EVENT

Keyword for the script command parser (required).

:Event#

This option defines the event number to be setup. If not specified, the

default value is Event :0. The values are :0, :1, :2, and :3.

WHEN

Keyword for the script command parser (required).

PC="####"

This option defines the Program Counter (PC) address to match on. 




"####" indicates a hex number with required quotation marks. This option 




provides support for 16 bits.

AND


Keyword for the script command parser (optional).

PCMASK="####"
This option defines the mask that is applied against the PC value. A bit 




value of zero is a don’t care and matches either 0 or 1 values in the PC. 




This option provides support for a 16-bit mask.

REGADDR="###"
This option defines the register address to match on. This option provides 




support for 12 bits.

RAMASK="###"
This option defines the mask that is applied against the register address




value. This option provides support for 12 bits.

REGDATA="##"
This option defines the register data value to match on. This option 




provides support for 8 bits.

RDMASK="##"
The Regdata mask option defines the mask that is applied against the 




register data value. This option provides support for 8 bits.

REGREAD

Match on register read. The options are ON or OFF.

REGWRITE

Match on register write. The options are ON or OFF.

FLAGS="##"
This option defines FLAGS value to match on. This is a 6-bit wide field. FMASK="##"
This option defines the mask that is applied against the flags value. This 




option provides support for 6 bits where the mask has a maximum value of 




"3F".

TRIGGERIN

Match on rising edge trigger. The options ON or OFF.

THEN


Keyword for the script command parser (required).

TRACE

This option sets one of the following trace actions: ON = Turn trace on, 




OFF=Turn trace off, or WHILETRUE=Trace is on while event is true. 

BREAK

This option sets the break option either ON or OFF.

TRIGGEROUT

This option sets one of the following trace actions: TOGGLE= Toggle




GPIO, PULSE = Pulse GPIO, or DISABLE = Disable action.

ARMNEXTEVENT
This option sets the arm next event action ON or OFF. When armed, the




next subsequence event is enabled, for example, Event 1 arms Event 2. 




The last event in the list, Event 3 re-arms Event 0.

Note: The parser requires all three keywords (EVENT, WHEN, and THEN).

An individual term within the WHEN statement can be reset with either the DISABLE or CLEAR command syntax:

EVENT :0 WHEN PC CLEAR THEN

EVENT :1 WHEN FLAGS DISABLE THEN

Examples: The following example is entered directly in the Command field as a single line:

Event :1 WHEN PC = "0400" AND FLAGS="04" AND FMASK="0F" THEN BREAK ON

Note: The “\” character can be used in a command batch text file to continue an event entry as shown in the next example taken from a ZDS II batch file, testevent.txt. The following example is from a script file that uses the batch-processing mode of the Command Processor:

EVENT :2 \

WHEN PC="2000" PCMASK="FFFF" AND \

REGADDR="200" RAMASK="FFF" AND \

REGDATA="20" RDMASK="FF" AND \

REGREAD ON AND REGWRITE Off AND \

FLAGS="2" FMASK="3F" AND \

TRIGGERIN ON \

THEN \

TRACE WHILETRUE AND \

BREAK OFF AND \

TRIGGEROUT TOGGLE AND \

ARMNEXTEVENT ON 

EVENTS Keyword
The entire event system can be enabled and disabled from the Command Processor using the EVENTS keyword followed by the ENABLE or DISABLE commands:

EVENTS ENABLE 

or

EVENTS DISABLE

The event system configuration can be viewed using the following command:

EVENTS SETUP

The entire event system configuration can be reset with the following command:

EVENTS RESET

The individual events 0-3 configurations can be reset with the following command:

EVENTS RESET :1 

1.5. RUNNING TRACE FROM THE COMMAND PROCESSOR
ZDS II—Z8 Encore! F642X Emulator allows you to run trace from the Command Processor toolbar. Each of the parameters is persistent, which allows for the repetition of the trace commands with a minimum amount of repeated data entry. Command Processor keywords have been added to allow for easy scripting to both configure and display trace. The following command structure for setting trace options can be used with the Command Processor toolbar:

Note: <> indicates optional commands; [] indicates required commands; [sp] indicates the space character. The entries are not case sensitive.
[TRACE][sp][SET][sp]<[BREAKONFULL] ON | OFF>[sp]<[FILTER] RAW | DISASM | UNFILTERED> 

These keywords and options are defined as follows:
TRACE

Keyword for the script command parser (required).

SET


Keyword for the script command parser (required).

BREAKONFULL
This option sets up the trace system to break run execution when trace is

full. The two options for this parameter are ON or OFF.

FILTER

This option sets up the filter to be used in the display or sent to a file. The 

three options for this parameter are RAW, DISASM (disassembled raw

trace), and UNFILTERED. RAW trace frames contain bus cycle 

information and can include emulator “idle” cycle information in the trace 

display. DISASM is disassembled trace that is processed RAW trace 

frames. The number of DISASM frames displayed is always less than the 

number of RAW trace frames requested. Extra time is needed by the IDE 

to get the RAW trace information and then disassemble it. UNFILTERED

is the exact information as stored in the trace emulator memory.

Examples 
The following are valid examples:

TRACE SET BREAKONFULL ON FILTER RAW

TRACE SET BREAKONFULL OFF

TRACE SET FILTER DISASM

The following command structure is supported for getting trace frames in different formats using the Command Processor toolbar:
[TRACE][sp][GET][sp][FRAMES="#####"] [sp]<[FILTER] RAW | DISASM | UNFILTERED>[sp]<"File to export to">

These keywords and options are defined as follows:

TRACE

Keyword for the script command parser (required).

GET


Keyword for the script command parser (required).

FRAMES="#####"
This sets up the number of trace frames to be loaded. If the number of 

frames specified exceeds the number of frames available, only the number

 of frames available will be returned. "####" indicates a number with 

required quotation marks. The trace buffer contains 65,535 frames, and the 

shortcut of "-1" requests the entire trace buffer.

FILTER

This option sets up the filter to be used in the display or sent to a file. The 

three options for this parameter are RAW, DISASM (disassembled trace), 

and UNFILTERED. RAW trace frames contain bus cycle information and 

can include emulator “idle” cycle information in the trace display. 

DISASM is disassembled trace that is processed RAW trace frames. The 

number of DISASM frames displayed is always less than the number of 

RAW trace frames requested. Extra time is needed by the IDE to get the 

RAW trace information and then disassemble it. UNFILTERED is the 

exact information as stored in the trace emulator memory.

"File to export to"
This is an optional parameter that specifies the file that the trace can be written to for review at a later time. The path and file name must be 

the last entries on the command line.

Examples
The following are valid examples:

TRACE GET FRAMES="6000" FILTER RAW

TRACE GET FRAMES="6000" 

TRACE GET FRAMES="-1" FILTER RAW "C:\TEST.TXT"

The current trace configuration can be viewed using the following command:

TRACE SETUP 

1.6. RUNNING ZDS II FROM THE COMMAND LINE
You can run ZDS II from the command line. ZDS II generates a make file (project_Debug.mak or project_Release.mak, depending on the project configuration) every time you build or rebuild a project. For a project named test.zdsproj set up in the Debug configuration, ZDS II generates a make file named test_Debug.mak in the project directory. You can use this make file to run your project from the command line.

1.6.1. Building a Project from the Command Line
To build a project from the command line, use the following procedure:

1. Add the ZDS II bin directory (for example, C:\Program Files\ZiLOG\ZDSII_Z8 Encore!_4.1.0\bin) to your path by setting the PATH environment variable. The make utility is available in this directory.

2. Change to the project directory.

3. Export a buildable project in make file format. For example: 

make Debug -f sampleproject_Debug.mak 

make rebuild -f sampleproject_Debug.mak 

1.6.2. Running the Compiler from the Command Line
To run the compiler from the command line:

1. Open the make file in a text editor.

2. Copy the options in the CFLAGS section.

3. In a Command Prompt window, type the path to the compiler, the options from the CFLAGS section (on a single line and without backslashes), and your C file. For example:
C:\PROGRA~1\ZiLOG\ZDSII_Z8Encore!_4.1.0\bin\eZ8cc -alias -asm -const: RAM -debug -define:_z8f64 -NOexpmac -NOfplib -intsrc -intrinsic -NOkeepasm -NOkeeplst -NOlist -NOlistinc -maxerrs:50 -NOmodsect -promote -quiet -NOstrict -NOwatch -optsize -localopt -localcse -localfold -localcopy -peephole -globalopt -NOglobalcse -NOglobalfold -NOglobalcopy -NOloopopt -NOsdiopt -NOjmpopt -stdinc:"..\include;C:\PROGRA~1\ZiLOG\ ZDSII_Z8Encore! _4.1.0\include" -usrinc:"..\include" -cpu:z8f64 -bitfieldsize:24 -charsize:8 -doublesize:32 -floatsize:32 -intsize:24 -longsize:32 -shortsize:16 -asmsw:"-cpu:z8f64" test.c

1.6.3. Running the Assembler from the Command Line
To run the assembler from the command line:

1. Open the make file in a text editor.
2. Copy the options in the AFLAGS section.

3. In a Command Prompt window, type the path to the assembler, the options from the AFLAGS section (on a single line and without backslashes), and your assembly file. For example: C:\PROGRA~1\ZiLOG\ZDSII_Z8Encore!_4.1.0\bin\eZ8asm -debug -genobj -NOigcase -include:"..\include" -list -NOlistmac -name -pagelen:56 -pagewidth:80 -quiet -warn -NOzmasm -cpu:z8f64 test.asm

1.6.4. Running the Linker from the Command Line
To run the linker from the command line:

1.Open the make file in a text editor.

2. In a Command Prompt window, type the path to the linker and your linker file. For example:

C:\PROGRA~1\ZiLOG\ZDSII_Z8Encore!_4.1.0\bin\eZ8lnk @e:\ez8\rtl\ testfiles\test\test.linkcmd 

1.6.5. Command Line Options
To learn more about commands see Table 9, Table 10, Table 11, and Table 12 that describe the command line options in ZiLOG Developer Studio IIZ8 Encore!® User Manual, pages 54 – 62. 

1.7. BRIEF INFORMATION ABOUT INTEGRATED EDITOR

The Edit menu lets you perform basic editing commands and contains the following options:

Undo - Select Undo from the Edit menu to undo the last command or action you performed.

Redo - Select Redo from the Edit menu to redo the last command or action you performed. 

Cut - Select Cut from the Edit menu to delete selected text from a file and put it on the clipboard. 

Copy - Select Copy from the Edit menu to copy selected text from a file and put it on the clip-board. 

Paste - Select Paste from the Edit menu to paste the current contents of the clipboard into a file. 

Delete - Select Delete from the Edit menu to delete selected text from a file. 

Go to Line - Select Go to Line from the Edit menu to display the Go to Line Number dialog box, as shown in Figure 3.

[image: image3.emf]
Figure 3. Go to Line Number Dialog Box 

Enter the line number in the edit field and click Go To to advance the program counter to the selected line of code. 
Find - To find text, use the following procedure:

1. Select Find from the Edit menu. The Find dialog box is displayed as shown in Figure 4.

[image: image4.emf]
Figure 4. Find Dialog Box 
2. Enter the text to search for in the Find What field or select a recent entry from the Find What drop-down list box. (If you select text in a source file before displaying the Find dialog box, the text is displayed in the Find What field.) 

3. Select the Match Case check box if you want the search to be case sensitive 

4. Select the Regular Expression check box if you want to use regular expressions. 

5. Select the Wrap Around Search check box to have the whole file searched. 

6. Select the direction of the search with the Up or Down button. 

7. Click Find Next to jump to the next occurrence of the search text or click Mark All to display a cyan box next to each line containing the search text.

NOTE: After clicking Find Next, the dialog box closes. You can press the F3 key to find the next occurrence of the search term without displaying the Find dialog box again. 
Find in Files - To find text in multiple files, use the following procedure: 

[image: image5.emf]
Figure 5. Find in Files Dialog Box 
1. Select Find in Files from the Edit menu. The Find in Files dialog box is displayed as shown in Figure 5.

2. Enter the text to search for in the Find field or select a recent entry from the Find drop-down list box. 

3. Select the file type to search from the In File Types drop-down list box. 

4. Use the Browse button ([image: image6.emf]) or the In Folder drop-down list box to select where the files are located that you want to search. 

5. Select the Match Whole Word Only check box if you want to only find words. 

6. Select the Match Case check box if you want the search to be case sensitive. 

7. Select the Look in Subfolders check box if you want to search within subfolders. 

8. Select the Output to Pane 2 check box if you want the search results displayed in the Find in Files 2 Output window. If this button is not selected, the search results are displayed in the Find in Files Output window. 

9. Click Find to start the search.

Replace - To find and replace text in an active file, use the following procedure: 

1. Select Replace from the Edit menu. The Replace dialog box is displayed as shown in Figure 6

[image: image7.emf]
Figure 6. Replace Dialog Box 
2. Enter the text to search for in the Find What field or select a recent entry from the Find What drop-down list box. (If you select text in a source file before displaying the Replace dialog box, the text is displayed in the Find What field.) 

3. Enter the replacement text in the Replace With field or select a recent entry from the Replace With drop-down list box. 

4. Select the Match Case check box if you want the search to be case sensitive.
5. Select the Regular Expression check box if you want to use regular expressions. 

6. Select the Wrap Around Search check box to have the whole file searched. 

7. Select the direction of the search with the Up or Down button. 

8. Click Find Next to jump to the next occurrence of the search text, click Replace to replace the highlighted text, or click Replace All to automatically replace all instances of the search text.
Breakpoints - Select Breakpoints from the Edit menu to view, go to, or remove breakpoints. You can access the dialog box (see Figure 7) during Debug mode and Release mode.

Go to Code. To move the cursor to a particular breakpoint you have set in a file, highlight the break-point in the Breakpoints dialog box and click Go to Code.

Enable All. To make all listed breakpoints active, click Enable All. 

Disable All. To make all listed breakpoints inactive, click Disable All.

Remove. To delete a particular breakpoint, highlight the breakpoint in the Breakpoints dialog box and click Remove.

Remove All. To delete all of the listed breakpoints, click Remove All. 

Note: For more information on breakpoints, see “Using Breakpoints”.

[image: image8.emf]
Figure 7. Breakpoints Dialog Box
Event System. Select Event System from the Edit menu to enable or disable the use of the events specified in the Trace and Event System dialog box (see “Trace and Event System”). When the event system is enabled, a check mark is displayed to the left of the command in the Edit menu.
Note: The Event System command is only available if you are using the Z8 Encore! emulator.

Clear Trace. Select Clear Trace from the Edit menu to delete the trace data when ZDS II is in Debug mode.
Note: The Clear Trace command is only available if you are using the Z8 Encore! emulator.
2. PRELIMINARY WORK

Carefully analyze theory of software ZDS II to manipulate procedures of Z8 programming. Prepare individual plan to realize analyses of how operate developing system executing programs written in codes of Z8:

( define files to use for quick tours presented in this manual,

( create folders to store data and results of experiments.

3. EXPERIMENTAL WORK

3.1. Execute all steps to process “EMULATOR QUICK TOUR” following the manual.
3.2. Explore operations realizing “COMMAND PROCESSOR QUICK TOUR”.
3.3. Complete experiment doing “RUNNING THE EVENT SYSTEM FROM THE COMMAND PROCESSOR”. 

3.4. Following instructions of the manual step-by-step explore mode “RUNNING TRACE FROM THE COMMAND PROCESSOR”.
3.5. Process analysis of how is organized “RUNNING ZDS II FROM THE COMMAND LINE”.

4. RESULTS AND CONCLUSIONS

4.1. Explain results obtain and write your explanations of information transformation in each file during experiments.

5. SELF TEST QUESTIONS

5.1. Emulating a program we do:


a). Process that use microprocessor of PC.


b). Process that use external hardware.


c). Analysis of codes written.

5.2. The Command processor means which of the following?


a). DOS command.


b). Instruction to be executed by PC microprocessor.


c). Special hardware of Z8.

5.3. Trace means which of the following?


a). The line drawn on the screen.


b). The line between two instructions of debugging code.

5.4. What is extension .linkcmd.

5.5. Command Go to Line of menu Edit means which of the following?

a). Direction to change state of Program Counter.

b). Direction to move text pointer to the line addressed.

c). Instruction to change number of current line.
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